AU07201 - HSBC - Data holder portal unavailable for new connections
Incident Report for Basiq
Resolved
Issue has been resolved: HSBC is working OK for new CDR connections.

As always, please report any questions or problems to us at support@basiq.io
Posted Jul 06, 2023 - 10:35 AEST
Identified
Some consumers selecting HSBC in the Basiq consent UI may receive an error, "Syntax error: Unexpected token 'I', "Internal s"... is not valid JSON".

This is due to changes in the authentication flow between data holders (in this case, HSBC) and data recipients, such as Basiq and our affiliates and representatives. Work was already in flight to add support for the new flow across all data holders; as HSBC has switched earlier than anticipated we will prioritise them and will switch as soon as possible. Unfortunately this may take several days as the changes are complex.

Only new connections are affected: existing connections are refreshing data without issue.

We recommend that our partners disable HSBC / AU07201 in their consent UIs until this incident is resolved.

Note that the HSBC connector status in your Basiq dashboard is operational: this is because refresh jobs (which form the bulk of data requests to the bank) are working OK.

We will update this ticket was soon as possible, for you to re-enable HSBC in the UI.
Posted Jul 05, 2023 - 15:01 AEST