AU13601 - Ubank - Certain proportion of jobs failing at the transaction step
Incident Report for Basiq
Resolved
Due to the frequency of website changes, this connector requires ongoing improvements that are continuously being worked on. Please use the institutions endpoint or Dashboard status page to determine the dynamic status of this connector and to determine when to offer this to your customers.

As always, please reach out to support@basiq.io if you have any queries or encounter any issues.
Posted Dec 08, 2021 - 14:03 AEDT
Identified
There is a problem with our Ubank connector that's causing some user jobs to fail on the transaction step.

This issue is caused by the mortgage accounts at Ubank. The bank displays an "initialAccountNumber" for these accounts that is different from the "actualaccountnumber". To find the actual account number, we must navigate through and open a new window and this account number is identical to that of one of the other main accounts (transactional or savings).

As a result, there is a discrepancy when retrieving transactions for these accounts, and the jobs are failing with the error message "Protocol violated by the connector: Number of accounts and transactions groups does not match". Based on this analysis, we have decided to not fetch the mortgage accounts for Ubank at this stage until the bank resolves this issue on their side.

Meanwhile, please reach out to support@basio.io if you have any further questions or concerns.
Posted Jul 19, 2021 - 13:22 AEST
This incident affected: APIs.