AU00301 - Macquarie - Connections failing on login step since Fri 11 Dec
Incident Report for Basiq
Resolved
Confirming that the Macquarie connector has been deactivated.

This is to avoid confusion while we work on the direct API integration. Work is in progress with selected partners to develop and pilot that integration, before releasing the connector for public use.

As always, please reach out to the team at support@basiq.io with any questions, problems or concerns.
Posted Mar 12, 2021 - 10:49 AEDT
Update
We will deactivate the Macquarie connector while we work on the direct API integration, to avoid any confusion from users trying to connect their accounts - when we know that this will not work until the API integration is complete.

We will update this notice to confirm when the Macquarie connector has been deactivated.
Posted Mar 11, 2021 - 17:29 AEDT
Update
Status update on the Macquarie connector issue:

The Macquarie internet banking website connector will no longer work, and we will be integrating with Macquarie's direct API instead.

Basiq have made architectural changes needed to support the OAuth workflow used by the Macquarie API, but we also need some work done on the partner side (i.e., the app developers who use our platform). One of our partners is working with us on this and we hope to have the connector back up using the direct API within a few weeks.

We are considering disabling the connector to avoid confusion, but for the moment it is listed in the institutions endpoint as a major outage. Please be aware that Macquarie connections will not work until the direct API integration is available.

Please subscribe to this outage notice for updates - or reach out to the team at any time, at support@basiq.io.
Posted Feb 10, 2021 - 16:21 AEDT
Update
Some changes are needed to the Basiq platform before we can support the Macquarie direct API. These changes are significant and unfortunately there is no quick fix: we are working on it as a priority and will have another update early next week.
Posted Dec 29, 2020 - 14:21 AEDT
Update
The issue is due to Macquarie detecting and blocking aggregators such as Basiq and other similar operators.

Due to the way that the blocking is implemented, Basiq was mis-interpreting the response as invalid credentials - we have now updated the error response in the API to "service-unavailable".

Macquarie are an independent third party and Basiq has no control over their website: they are under no obligation to grant access to aggregators. We will continue to work on this complex problem over coming days and will update this notice with progress.
Posted Dec 16, 2020 - 09:03 AEDT
Identified
Jobs for Macquarie Bank are currently failing with invalid-credentials responses despite correct credentials.

The team are investigating and will update this notice with progress, details and advice.

As always, please reach out to the team at support@basiq.io with any questions or concerns. Thanks.
Posted Dec 15, 2020 - 23:16 AEDT